Welcome to the Inedo Forums! Check out the Forums Guide for help getting started.

If you are experiencing any issues with the forum software, please visit the Contact Form on our website and let us know!

  • Cargo feed returning 500 Internal Server Error

    Support cargo error 500 proget
    3
    0 Votes
    3 Posts
    20 Views
    J
    Hi @atripp, We have now updated to ProGet 2026.3 and can confirm this is now working as expected. Thank you for your prompt help.
  • 0 Votes
    2 Posts
    12 Views
    stevedennisS
    Hi @vdubrovskyi_1854 , Without knowing which specific package you're referring to, it's hard to give a more specific example. Historically, Packagist was effectively a database of "GitHub Repository pointers" and Composer was effectively just a wrapper around the Git client. They can both still operate in that mode, and needs to for older, non-standard packages. I suspect that's the type of package you're referring to here. ProGet's Composer feeds work with "packages" (i.e. not the GitHub pointers), which account for nearly all of the modern packages on Packagist.org. For the small number of packages that don't follow the standard (mostly older, legacy packages), you'll need to download them, properly package them, and then upload them to follow the standard. Unfortunately there's no technically feasible/sensible way to solve this problem - since it would require ProGet to serve as a GitHub pointer database, which just doesn't make sense. Cheers, Steve
  • Unable to login with Active Directory with Proget 2026.1

    Support
    7
    0 Votes
    7 Posts
    45 Views
    aristo_4359A
    @pg_user_8607 Given the fix is about searching in AD I think the pull request is indeed related, as there is no other error I can find other than unable to find the user(s) in the User Directories Test.
  • After upgrading to 2026 https no longer works

    Support
    5
    1 Votes
    5 Posts
    49 Views
    ValentijnV
    Hi, I was on a short vacation but today I upgraded to 2026.3 (build 14) without any problems. This probably fixed it: PG-3299 2026.3 FIX: Hostname based binding fails when hosting on Windows with HTTP.SYS Kind regards, Valentijn
  • Scheduled Task is failing due to invalid script identifier

    Support
    3
    2
    0 Votes
    3 Posts
    24 Views
    B
    Hi Alana, Just wanted to let you know that restarting the service did fix the issue. Thank you for the suggestion. Brandon
  • 0 Votes
    3 Posts
    19 Views
    A
    Hi @gdivis , thanks for the quick turnaround. Everything is working as expected with the new version. Cheers
  • PEP 700 conformance for PyPI feeds

    Locked Support
    13
    0 Votes
    13 Posts
    101 Views
    atrippA
    @Ashley thanks for letting us know!
  • 0 Votes
    2 Posts
    17 Views
    atrippA
    Hi @brandon_owensby_2976 , Looks like this is a regression in BuildMaster 2025 from a library upgrade; we will address it via BM-4017 in an upcoming release, either this Friday or the following cycle. Thanks, Alana
  • Container image size calculation does not always work

    Support
    3
    1
    0 Votes
    3 Posts
    13 Views
    P
    Thank you very much for the detailed answer!
  • SCA page throws an exception for anonymous users

    Support
    2
    0 Votes
    2 Posts
    11 Views
    atrippA
    Hi @pg_user_8607 , Thanks for the bug report; this will be fixed via PG-3296 in the next maintenance release (scheduled next Friday). It was a problem in the redirect to the /log-in page, so of course if you log-in first, the error will not occur. Cheers, Alana
  • 0 Votes
    4 Posts
    21 Views
    Dan_WoolfD
    Hi @cssccmgroup_4090, I created a private ticket on your behalf. You can see it by navigating to https://my.inedo.com/tickets. Please upload the SBOM through that ticket. Thanks, Dan
  • 0 Votes
    2 Posts
    10 Views
    atrippA
    Hi @vdubrovskyi_1854 , Thanks for the detailed reproduction information; I debugged/fixed this, and it will be in the next maintenance release of ProGet via PG-3290, scheduled for Friday of this week. As for the underlying issue, the problem was that there were two composer.json files in the zip file. ProGet was opening build/composer.json instead. I didn't test a work-around, but in theory you should be able to just download the zip file directly, delete build/composer.json from it, and upload it to ProGet. I also updated the error message to make somethign like this a little easier to track if it comes up again ("An unexpected error occurred: Error parsing "voku-simple_html_dom-716822e/build/composer.json" as a Composer manifest file (Missing required property: name).") Cheers, Alana
  • SBOM/RMetadata support for pypi feed type

    Support
    3
    0 Votes
    3 Posts
    29 Views
    B
    Thanks for the quick turn around. We are happy to wait for next release, and can report back if we find any further issues.
  • Project-scoped permissions not working as expected

    Support
    2
    7
    0 Votes
    2 Posts
    18 Views
    rhessingerR
    Hi @Nils-Nilsson, Thanks for bringing this to our attention. This looks to be a regression that happened right before release. I have created a ticket, PG-3289, to track the fix and we will release it this Friday in ProGet 2026.2. Thanks, Rich
  • Working with Secure Resources / Secure Credentials

    Support otter otterscript
    3
    0 Votes
    3 Posts
    20 Views
    atrippA
    Hi @jimbobmcgee , Very cool! We did not forget about this, just got a bit behind on feature requests (which this got classified on) with ProGet 2026 coming out. However, we've added this to our BuildMaster/Otter 2026 roadmap to review and incorporate. We plan to start on that relatively soon, and it may be something we can easily back-port to BuildMaster/Otter 2025. We'll update once we make progress on this :) Cheers, Alana
  • [Feature] ProGet: Set initial stage on builds scan

    Support
    2
    0 Votes
    2 Posts
    35 Views
    atrippA
    Hi @Nils-Nilsson , We've added this to our ProGet 2026 roadmap; there's an additive feature called "Build Pipelines" that just didn't make it in time for release, so this will fit nicely into that. FYI the main thing that this new pipeline offers is the ability to create multiple pipelines and assign them to different releases. Thanks, Alana
  • 1 Votes
    10 Posts
    48 Views
    N
    Post moved to Project-scoped permissions not working as expected
  • pgutil health fails after updating to proget 2026

    Support
    3
    0 Votes
    3 Posts
    18 Views
    felfertF
    Thanks a lot @atripp for the quick fix. Problem solved Cheers -Fritz
  • Help with upgrading

    Support
    2
    1
    0 Votes
    2 Posts
    15 Views
    gdivisG
    Offline installers are available here which you can use to upgrade these older versions: https://my.inedo.com/downloads/installers
  • 0 Votes
    4 Posts
    21 Views
    stevedennisS
    Hi @ybaskar-temp_3339 , Thanks for confirming that. I think it'd be worth exploring how to change those migration/environment constraints. While it's unfortunate to "lose history" and need to navigate to a separate instance, there's a moderate amount of risk in things simply not working the way it did before.... we're talking a decade of evolution, including platform, architectural, and even usage changes. That said, for an in-place upgrade, here's the approach that I would use. Use the Legacy (Traditional) installer to get to BuildMaster 6.1. Verify things work as expected on BuildMaster 6.1, agents updated, etc Upgrade to BuildMaster 6.2, again using the traditional installer Verify things work as expected in same manner Uninstall Ensure all components (iis site, service, program files.... except database, artifacts) have been removed Install BuildMaster 2025 as per normal, pointing to existing database Note that there's a decent change that you'll run into database or binding errors after #7, so make sure to run buildmaster.service.exe run from the commandline to better see messages and errors if things don't start up. Cheers, Steve